La fonction SOMME.SI()

Vous connaissez probablement la fonction SOMME(). Elle fait partie de celles qu’on apprend lorsqu’on fait ses premiers pas sur Excel et permet tout simplement d’aditionner le contenu de chacune des cellules qui sont visées (on parle de plage de cellules).

Connaissez-vous la fonction SOMME.SI() ? Elle permet également d’aditionner le contenu d’une plage à ceci près qu’elle inclut la valeur d’une cellule seulement si une condition est vérifiée.

Exemple 1 :

Dans l’exemple ci-dessous, nous avons des achats d’affaires de bureau. Nous souhaitons connaitre le nombre de produits vendus qui ont une certaine couleur.

Saisie de la formule Somme.Si() pour calculer le nombre de produits verts.
Somme.Si()

 

Pour ce faire, rien de plus simple. En bas de tableau, insérons la formule suivante :

=SOMME.SI(C2:C17, »Vert »,D2:D17)

 Explications :

La formule contient deux plages de cellules et une chaine de texte.

  • C2:C17 correspond à la plage des critères. Cette plage sert à vérifier la condition.
  • « Vert » est la condition que doit vérifier la cellule pour prendre en compte la valeur dans la somme.
  • D2:D17 est la plage de la somme. C’est à partir de celle-ci que les valeurs sont aditionnées si la condition qui lui fait face dans la colonne des critères est vérifiée.

Dans notre exemple, pour chacune des cellules qui contiennent Vert, Excel ajoutera la valeur de la plage des quantités.Le mot Vert se retrouve dans les cellules no 6, 9, 10 et 14 (c’est leur position dans la plage C2:C17).

Les valeurs aditionnées sont celles des cellules des positions 6, 9, 10 et 14 dans la plage D2:D17 :

9 + 15 + 400 + 18 = 442

 

Les deux plages ne sont pas nécessairement l’une en face de l’autre, ni l’une à côté de l’autre ! C’est la position de la cellule dans la plage qui compte.

Exemple 2 :

 

Saisie de la formule Somme.Si() pour calculer la somme des commandes supérieures à 800.
Somme.Si()

 

Cette fois-ci, cherchons à calculer la somme des achats qui ont atteint ou dépassé 800 pièces par commande.

Pour ce faire, rien de plus simple, voici la formule :

=SOMME.SI(D2:D17, »>=800″,D2:D17)

La condition est logiquement « >=800 ».

Le résultat vaut 2000 (800 + 1200).

 

Vous remarquerez que la plage des critères est cette fois identique à la plage de la somme.

Dans ce cas, Excel propose simplement de supprimer le dernier champ qui n’est en fait pas obligatoire :

 

Somme.Si()
Somme.Si()

 

 

Un café ? Sans sucre…